• Android 4.1 & below has compatibility issues on our app that is why our app cannot be used or installed on Android 4.1 & below. In order to install the app your phone must have Android 4.2 and Up, on Iphone IOS it should be IOS 10 and above.
English